edited January 2016 in ORK Support
I have 3 prefabs in my scene - a rack of fish, a firepit, and a well. I've assigned a unique scene object to each, "Search," "Cook" and "Use." However, when I run the game, all three take on the "Search" scene object. Is this a bug? If I change the scene object paired to the Fish Rack, the other two change in suit. My understanding of scene objects is that I can access the %n name with my Interaction HUD, and the name should return whatever I set the corresponding Scene Object to.

This is also happening to Scene Changers - they've all taken the Scene Object name of the first changer.
Post edited by Jerseyware on
  • Can't confirm that. The Scene Object components in my test all displayed their correct name in the interaction HUD. Make sure you've saved the changes to your scene and are working with the latest ORK 2.6.2 - there was bug with changing components not marking the scene as changed (i.e. not saving the changes).
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Just to confirm, I'm attaching the Scene Object and Event Object to the prefab itself. There is also a box collider marked 'Is Trigger' for the IC to hit. These are all components of the prefab.

    I will remove these prefabs entirely and re-create them with the Scene Objects tonight to test. Thanks.
  • So I removed the prefabs and the scene connections, saved the scene, ran it, put them back, saved it, ran it, and they're working properly again.

    Oddly now parts of my menus either don't appear, or disappear when transitioning between menus. I can't get my escape menu to appear at all, and if I close and re-open the game menu, parts appear seemingly at random (menu small, menu big, menu info, top info). As these parts disappear, my game hud's parts disappear as well.

    Version 2.6.2 of ORK.
  • Can you send me a test Unity project to contact@orkframework.com?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • One of the reasons we all love you--your willingness to look at our test projects. I was just looking at an old thread in the Unity forum that compared ORK to another rpg framework--don't know how I got there but I was looking for whatever it was I was looking for and they quoted wtyson's thread about how we all had a whole bunch of reasons to thank you and they said you are very much loved because you are so responsive. And I would say that is certainly true.
  • Will test it after I've finished downloading it - in which scene is this happening?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • '01-TavernTest-TerrainComposer-Rocky' is the scene name, but I'm not sure if any of this is connected to the way the events load that scene in after the 00-CharacterCreation scene.
  • Finally tested it - and worked as expected, the 3 prefabs had the correct scene objects selected and displayed their names correctly ...
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I'm at a loss. All three say the same thing on my side.

    Doubt it's any use trying to resolve this further then, I'll load a backup. Thanks for taking a look anyway.
  • Since you've sent me a unitypackage the project on my side was completely rebuild, i.e. it might be an issue with your Unity project's library ... maybe exporting everything as a unitypackage and importing it into a new project will solve it for you as well.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Ok, I imported the package I sent to you, and the scene objects are now working as expected. If you wouldn't mind, while you have it imported already, can you try running through into the game scene and pressing Escape and Tab, and tell me if you see the Demo Menu (there should be Menu Info, Menu Small, and Menu Big in the Tab menu, and Menu Small in the Escape menu)? These pieces don't appear properly anymore, even after reimporting.

  • Pressing Tab allone brings up the menu correctly, using Escape first (which is used to call a different menu in your setup) doesn't work that well ...
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • It's weird. Tab will work ok on its own sometimes(if you open and close the menu too many times, it starts to bug out), but if you press ESC, that won't work, but you can back out of it by pressing ESC again, and then sometimes parts of the HUD don't show anymore, and pressing Tab again will only bring up some parts of the game menu.
  • This remains an issue. I haven't been able to resolve by reimporting, or by disabling/re-enabling components.
Sign In or Register to comment.