edited December 2015 in ORK Support
My 00-Start scene loads and the menu displays. I click "Start New Game," same as always, the menu disappears, and...that's it. The screen doesn't fade and nothing loads. There are no errors, and the _ORK object says "Changing Scene: True." I've tried to make a new start scene to see if that helps, but it made no difference.

My most recent changes were to the GUI Box for the menu, I made the text larger and shifted the position of the menu. My spawn point at the load scene has not changed, nor has my Start event.

I have no idea what's wrong. Has anyone ever seen this?
Post edited by Jerseyware on
  • edited December 2015
    File -> Build Settings, make sure the target scene is in there.

    If that didn't work you might want to try Assets -> Reimport All. This takes forever to do in large projects, but it helped me when I had a similar problem.
    Post edited by Jade on
  • edited December 2015
    @Jade - I checked for the target scene, and removed it / readded it just to say I did. It throws an error when the scene isn't in the build list anyway.

    I tried to reimport just the ORK Framework folder, but that didn't help. I'm gonna try reimporting all later tonight since it takes so long.

    I've also tried changing the target scene, and loading my oldest backup. No change.

    UPDATE: I stuck a game starter in my first scene and it looks like something's got the whole thing stuck. I can't move, the time/day system gets to 0.0004 before stopping. I've dug through all my events and controls, menus, global events, I can't find anything that would cause this. The scene just -stops- as soon as it loads. I'm thinking the scene changer in the main menu gets stuck because this scene is stuck, which is all the stranger because I didn't change anything in this scene. Still digging.

    Reimport All did not fix the problem.
    Post edited by Jerseyware on
  • edited December 2015
    I know this won't make you feel better but if you haven't, you should always keep a backup of your last working game, anywhere on your hard drive. That way if something like this happens you can go back and then try to figure out what you added or changed that broke things. I've had to go back many times and if I didn't have an old file, I'd be doing a whole lot of work over again.

    Maybe try changing the name of your first scene to 0 Start--and make sure that matches the name of the scene that's loaded in the ORK Framework editor--don't have ORK open right now but it has to be in Main menu Settings or menu settings somewhere - which scene your main menu loads.

    Do you have a game starter in your main menu scene?

    If your 00 Start is your loading scene for your game, what's your main menu called--something like 0 Main Menu?

    In my main menu I have the Ork Game starter and in game start settings it has my ORK project file.
    Post edited by Catacomber on
  • Sounds like a case of Time Scale being set to 0. Go to Edit > Project Settings > Time in the Unity menu and check if Time Scale is set to 0. If it is, set it back to 1 (the regular time scale).
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • OHMYGODI'MSORELIEVED. I don't know how on earth that got set to 0, but Time Scale was the issue! Thank you so much!
Sign In or Register to comment.