edited September 2015 in ORK Support
Hi folks, this is driving me crazy.
The issue: the walk animation is never triggered, by default always goes to run.

I´ve been playing changing the move speed parameters under combatant move settings with no result.

Setup: Model, rigged in Mixamo with Humanoid setup to share animations
Animations following the tutorials for animator controller

Field Animations: idle, walk, run, jump, attack (to trigger the Battle)
Battle Animations: stand, attack, cast, victory, died...

Use case: In field mode I just want to use the Field Animations

I must be doing something wrong because it doesn´t make any sense the time spent setting this up.
Post edited by RustedGames on
  • edited September 2015
    your set min run speed at something like 4 and max walk speed to 4 and that should work. also make sure your character controller is set up to.
    Post edited by wtyson on
    new website can be found here http://www.fore-loregames.com

    Follow the game Development on Twitter https://twitter.com/Fore_Lore_Games

    or check out the face book page here https://www.facebook.com/ForeLoreGames
  • Thanks wtyson, from the combatant animation and movement settings I have:
    Use Auto Animation to true
    Minimum Run Speed = 4 and bellow in Movement Settings->Walk Speed Settings->Value = 4
    Is that what you meant? there is no max walk speed and making this changes has no effect in the disability to use to walk animation.
    Character controller is good following the setup tutorials
  • At the end I manage to script a custom character controller in order to handle this scenario and take advantage of blend trees.
    Thanks for the hint anyways.
  • Care to share it? Same issue here.
  • Hi David, sure I can share but takes into account that this is not a generic solution and only solves the particular use case the prototype I´m working on.
    1) First you need to follow the tutorial on how to use a custom character controller.
    2) Then I´ve created the Animator Controller following Unity´s standard Assets package and the ThirdPersonController that comes with modifying it to match my animations. In this Animator Controller I need to have a set of animations blend trees to play in Field Mode and other set to play in Battle mode.
    3) From ORKFramework->Combatants->your combatant you need to uncheck Auto Animations since this will be handle in your script.

    The content of the script is a modified version of what unity´s thirdpersoncontroller delivered since I need to handle the set of custom animations but at the end the result is that connecting the game pad I´m able to tilt the stick to get from idle to walk to run.

    I´m still using ORK´s Camera Controller until I get the time to script it for the gamepad right stick.

    hope this help and send PM if you want more detail.
Sign In or Register to comment.