edited February 28 in ORK Support
I'm having an issue where my custom movement ai function is only being called on one combatant. When I delete that combatant another combatant will start moving. What's weird is they aren't even the same combatant. I've hooked ORK's move AI (Hunt AStar Dungeon) into a component named AStarWrapper (speed, position, stop are function names). I use step debugger and see that these functions are only being called once (on the combatant who is moving) and not on the ones who are still. When I delete the moving combatant, another single combatant will start moving. I'm thinking it's an ORK thing I don't understand because ORK is the thing calling these move functions on only 1 combatant?

I'm spawning the combatant via DunGen's 'random prefab' spawner with a combatant on the object.
Post edited by foxx on
  • What's the overall setup here - e.g. which battle system are you using and is this even during battle? Are these individual combatants or are they from a spawned group?

    I assume you've set up your custom functionality in the move AI via the Custom component type? Which of the functions is being called once, the position method?


    E.g. if this is used during turn based battles only allowing the combatant currently performing their turn to use the move AI could look like that.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.