edited January 23 in ORK Support
I start new game, save (using save/load menu) and then still in running game, call load game menu, load my save slot without issues.

Now, after I turn off the game, load the save slot from Main Menu and then in running game again calling load game menu and trying to click my save slot, I get following error:

NullReferenceException: Object reference not set to an instance of an object
ORKFramework.Menu.Parts.InventoryMenuPart.ChangeCombatant (ORKFramework.Combatant old)
ORKFramework.Menu.MenuScreen.set_Combatant (ORKFramework.Combatant value)
ORKFramework.MenuHandler.Clear ()
ORKFramework.ORK.Clear (Boolean control, Boolean initVariables)
ORKFramework.SaveGameHandler.Load (Int32 index)
ORKFramework.LoadGameChoice.ShowQuestion ()
ORKFramework.LoadGameChoice.ChoiceSelected (Int32 index, ORKFramework.GUIBox origin)
ORKFramework.DialogueContent.OkPressed (Boolean fireOnClick)
ORKFramework.DialogueContent.ChoiceClicked (Int32 index)
ORKFramework.Behaviours.UIChoiceButtonComponent.ClickDelegate ()
ORKFramework.UIClickComponent.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) (at C:/buildslave/unity/build/Extensions/guisystem/UnityEngine.UI/EventSystem/ExecuteEvents.cs:50)
UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) (at C:/buildslave/unity/build/Extensions/guisystem/UnityEngine.UI/EventSystem/ExecuteEvents.cs:261)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1)
ORKFramework.Behaviours.ORKInputModule:ProcessMousePress(MouseButtonEventData)
ORKFramework.Behaviours.ORKInputModule:ProcessMouseEvent(Int32)
ORKFramework.Behaviours.ORKInputModule:ProcessMouseEvent()
ORKFramework.Behaviours.ORKInputModule:Process()
UnityEngine.EventSystems.EventSystem:Update()

I can only load my save slot from Main Menu the first time game initializes. Any help please?
Post edited by Machal on
  • Did a quick test and worked fine here. From the error it's somehow related to an inventory menu (part) ...

    Is the inventory menu open while loading (or trying to load) the game?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited January 24
    I've had inventory menu representing icons as HUD due to tooltips opened and didn't realized that.

    Closed it before the loading happened and worked fine. Thanks!
    Post edited by Machal on
  • Still, that shouldn't happen, I'll check it out :)

    Also, you can have tooltips in HUDs, e.g. Shortcut HUD elements in Combatant HUDs.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited January 25
    Shortcut HUD...that's really cute, but let's say you want a simple Menu UI with custom icons and hovering over them shows what type of menu it is. Not based off some combatant :) I find the Inventory Menu tooltip and spawning a GUI box with fake inventory really flexible.

    IMHO, Info HUD with Tooltip is the only challenge to it :)
    Post edited by Machal on
  • Ah, ok - I thought it was about items due to the inventory menu :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.