Hello,

Running through the demo and evaluating the Ork framework and ran into this problem...

In tutorial 09. Attributes

Under Combatants > Combatants
When changing attribute settings for Race to "Human" and Size to "Medium" neither options are available. The only options available are Attack attribute start values and defense attributes start values.

I'm using version 2018.4.8f1 Personal if that helps.

Is there a different version for the tutorial I'm supposed to use?
  • Are you sure you've set up the Defence Attributes in Status > Defence Attributes in the ORK editor?
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited September 4
    I am sure,

    Under Status > Defense Attributes

    0:race
    1:size
    with 0 through 5 sub-attributes for race and 0 through 3 for size. Each with the correct name from the previous tutorial.
    Post edited by Privatus on
  • Sorta fixed it, I rebooted Unity and now under

    Combatants > Combatants

    0:Brown Pants

    Defense Attributes > Attribute Settings

    Defense Attributes Start Value 0 -> now shows Defense Attribute 0:Race
    Defense Attributes Start Value 1 -> 1:Size

    This updated the Status Effects page...

    So basically rebooting unity fixed the issue. Its not behaving exactly like the tutorial shows but I think this will work for the demo. I'll update if anything else fails to load up correctly.

  • Which ORK version are you using? You can find it in Editor > About in the ORK editor.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • It's at the top of the thread 2018.4.8f1. I'm getting a bug with the battle menu not displaying correctly when a battle begins. Basically its stuck on the bottom left side of the screen with the name box tab showing. I can here the selections being made when I press the arrow keys but the box they are contained in stays locked out of sight below the name box. What might cause this behavior? I've gone back though the checked all the GUI box settings and they appear to be correct for the battle menu.
  • Fixed it,checked:
    Base Settings -> Limit to screen.
  • You posted the Unity version, not the ORK version - the latest version is currently 2.26.1 :)

    Anyway, sounds like your issue is that youf battle menu's GUI box is defined at the wrong position. Make sure that the Bounds (content box) of your GUI boxes are set up within the bounds of the Default Screen Size (which is defined in Game > Game Settings).
    ORK handles UI scaling for you based on the default screen size, so all your UI should be defined within those bounds.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited September 18
    Duh Sorry,

    ORK version 2.26.0 - Time to update thanks

    Good to know thanks,
    Bounds content box: x:0 Y:800 W:300 H:400
    Default Screen size: x:1280 y:800

    Not sure why it was hanging out below the screen but it was behaving like the start pixel for rendering was the top right of the box. Limit to screen fixed the issue but something seems off.

    In other news under damage and flying texts:

    When brown pants attacks evil pants evil pants turns completely black and no flying text is displayed. Then when evil pants returns the attack brown pants is turned completely black, no dice on the flying text either.

    I have double checked the notification1 event asset and gone back through the flying text 0 and 1 settings for mp and hp several times.

    Once I turned off the "Use flash setting" the ninja effect stopped occurring but still no flying text.

    https://drive.google.com/file/d/1qou9zSAhqJc7YRhntJ_A0zHdM0piabtY/view?usp=sharing

    No clue as to what causes this behavior, I will say I have seen the number 0 pop up briefly before the ninja effect takes over but its gone as soon as it appears.
    Post edited by Privatus on
  • What's the Anchor of your content box? Since it's placed at X=0, Y=800, it'd need to use the Lower Left anchor to be fully visible. I.e. the lower left corner of the GUI box will be placed at that position (which is the lower left corner of the screen).
    Limit to screen will simply force your GUI box to be within the screen's bounds :)

    Evil pants turning black is probably due to your status value's flash settings being wrong. Make sure the start color is white (with full alpha) and you're fading red, green and blue.

    The flying text immediately vanishing is probably due to your move event not having any wait time. Make sure you've enabled wait options or added a Wait node that gives the text enough time to be displayed. Or, if not using a move event, make sure the Destroy Time is set to something higher than 0 (e.g. 3 seconds).
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited September 19
    Just wanted to add im having problems with this too. All of a sudden all my guibox's (Which were within screen bounds earlier) are now outside of the bounds of the screen for no apparent reason. Like my Top info box is now cut in half with the other half chilling outside the top of the screen.
    I haven't looked into it much yet since im working on combat. But, at least in my game preview window all the windows are suddenly slightly off.
    Post edited by Wrofir on
    Warborn
  • Hm, which ORK/Unity version and GUI system are you using? Also, did this happen after updating ORK (or Unity) or just happened within the same version?
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited September 23
    I messed around with the alpha setting and found that I had it set to fade from 0 to 1 in .25 seconds on the notification1 event. After changing it to 255 the fade effect is working correctly... most awesome effect thanks... however the ninja effect is still there for both the flying text and the combatants.

    I changed the color of the wait .25 fade from black to red... no change in color still black on the floating text... If I disable the flash effect the ninja effect on the combatants remains on the text but not on the combatants.

    https://drive.google.com/file/d/16Giyx2TIeEj568f_-aWQPysCXjEEpQ_v/view?usp=sharing

    I think for the evaluation purpose it works, but the tutorial might be off a bit. Thanks for the help this thread is clooooosed!
    Post edited by Privatus on
Sign In or Register to comment.