Just what the title says.
A project made with Unity 2019 doesn't include the UnityEngine.Networking module, which Makinom Free needs to work.
The closest thing is the Unity Multiplayer HLAPI package, which I believe is where they moved that.

Also, it just doesn't break Makinom, it breaks everything as it tries to reference some unreferencable thing or something. I don't know, I'm just slightly pissed about that is all.

Steps to reproduce:
1) Make a new project
2) Add Makinom Free
3) Enjoy fresh errors

PS: I don't know if this happens in the Makinom Pro version, too, but I'd assume it might. Just made clear I used Free because that's what I used. Hopefully this'll be fixed soon (Or I'll find out how to call an ORK event directly from code or something, I'm not picky, but Makinom could come in pretty handy anyway)
  • I'll be on it, strange that this didn't come up in my tests ...
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I guess there's always the chance that my installation of Unity is broken, I'll try in a different computer when possible to rule out as much as I can on my side.
  • No, it's definitely Makinom - I'm currently working on a version for Unity 2019, should be available sometime this week :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Makinom 1.14.1 is now available and supports Unity 2019.

    Naturally, Makinom for Unity 2019 no longer includes networking/multiplayer functionality, as Unity removed that feature :)
    It's still available in the other versions (i.e. Unity 5.6, 2017 and 2018).
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Nice to hear. Thought technically Unity only removed networking/multiplayer as a thing included on everything, by pushing the networking stuff into an optional package called "Unity Multiplayer HLAPI"... As far as I know. Which isn't much, considering I haven't any interest for the time being in making anything multiplayer.

    Though I guess that was the fastest and easiest way to make a Unity2019 compatible version just to have it not break at all.

    I don't even know why I'm saying all that when I should be thanking for the quick response time on fixing the problems.
  • AFAIK the multiplayer HLAPI package doesn't contain everything that was part of UNet, but I might be wrong there. In any case, Unity deprecated UNet, so I'm not really up to waste a lot of time to get this running in Unity 2019+ :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.