I have a little issue in that my player will not spawn when using a spawn point. From the Main Menu to my first scene, I got around it by using the 'easy' option in the tutorial. However, when I add a scene changer and add the spawn point following the tutorials, nothing I can do will make the player spawn in my other scene.

I have checked all spawn IDs and these match up. I have removed the components and re-added them, following the tutorial to a T. I've also tried spawning based on position rather than Spawn Point. Nothing.

Having searched the forum, no one seems to have the same issue as this so I'm a bit confused :) Using Unity 2018.1

Any suggestions on what I could try would be a big help!

  • Just making sure: is your new scene (that you're trying to spawn in) part of the game build settings?
  • edited December 2018
    In addition to checking that, is your player tagged Player? Do you have a game starter in the first scene of your game? Is the spawn point in the other scene sufficiently above the ground--high enough? What does your event look,like for spawning the player in the first scene?
    Post edited by Catacomber on
  • The player doesn't need to be tagged as player, since ORK keeps track of its player without that :)

    Anyway, do you get any error message in the Unity console? Does Unity change to the new scene and just not spawn the player, or doesn't it load the new scene at all?
    If you're enjoying my products, updates and support, please consider supporting me on!
  • Hi all,

    Apologies for the delay in replying, my internet has been down the last few days!

    I have checked all of the suggestions but nothing changes.

    @gamingislove - the scene changes, but no player spawn at the spawn point and no error messages in the console.

    I have a scene changer that changes to my new scene. Set to SpawnPoint ID of '0'. Target scene is defined in the Scene Changer and is set to Trigger Enter. Nothing else changed.

    In my target scene, I have a Spawn Point with an ID of 0 and a scene changer sending the player back to the previous scene. Spawn Point is way away from the Scene Changer collider. All scenes are in the build settings.

    Scene changes, no player spawn.

    Thanks and I hope you all had a Merry Christmas! :)
  • Hm, is there an actual player available in ORK? I.e. you've added a combatant to the active player group?
    If you're enjoying my products, updates and support, please consider supporting me on!
  • Ok, so a bit of an update.

    I stripped out all the ORK components from my scene and added them in from scratch. This allowed me to use Option 2 of spawning the player from the main menu (rather than the easy way) and it works fine.

    The only issue I have now is the Scene Changer. I have tried three different scenes, including the one that came with the tutorial resources and it just won't spawn the player at the spawn point. I have tried new Scene Changers at different positions and new spawn points with various ID's and positions. Nothing.

    I started a new project using only ORK and everything works fine which leads me to believe something in my current project is stopping the player from spawning. What that is, I've no idea as nothing I have would affect spawning, especially without throwing up any errors.

    All I'm using is Invector and a few model assets without any demo scenes.
  • Hm, did you change the Unity wrapper settings in Game > Game Settings? Especially using custom load scene functionality.
    If you're enjoying my products, updates and support, please consider supporting me on!
  • All four boxes unticked, is that correct?
  • Yes ...
    Hm, could you send me your Unity project to E.g. zip it up and upload it on dropbox or something and send me the link :)
    If you're enjoying my products, updates and support, please consider supporting me on!
  • Did you find a fix for this issue, I'm having the same problem. Character spawns in initial scene from main menu. Any other scenes however the spawn points do not work, the character is not there
  • I didn't receive a test project to check out, if you've got one where this happens, please send it to (as stated above, e.g. upload it to dropbox and send me the link).
    If you're enjoying my products, updates and support, please consider supporting me on!
  • edited March 12
    Ok I have emailed you the link to the project, thanks for your help.
    Issue Solved Now.
    If anyone else has this problem turn off Invector’s Third Person Controller component on your player’s prefab – click on Open Properties and Locomotion and disable Use Instance.
    Post edited by Dreamwalker23 on
Sign In or Register to comment.