I am testing the results of tut 21. I go to the battle and attack. The particle starts then I get the exception. I can unpause the editor and the battle continues. I switched to use particles from Cartoon FX Pack by Jean Moreno (JMO) with the same result.
My first thought is that it looks like the deprecated ParticleEmitter is finally removed. I am about to switch from the Ork dll to source code to debug this.

This is the stack trace I get:

[Exception] MissingMethodException: void UnityEngine.ParticleEmitter.set_emit(bool)
EmitParticlesStep.Continue() :0

EmitParticlesStep.Execute()
:0

BattleEvent.ExecuteNextStep()
:0

BaseEvent.StepFinished()
:0

BaseEvent.Tick()
:0

BaseAction.Tick()
:0

BattleActionHandler.Tick()
:0

Battle.Tick()
:0

ORKCore.FireTick() <035c8897f8cf491cbae33e9b8dc9bf96>:0

ORKHandler.Update() <035c8897f8cf491cbae33e9b8dc9bf96>:0
  • No need for that - seems like Unity 2018 drops support for the legacy particle system (or at least changes something).

    In any case, Unity beta versions are not supported by ORK, you'll have to stick with official Unity releases (5.6 or 2017.x) for the time being.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • Thanks,

    Yes, I think that is a great idea! How soon after release do you expect to support 2018.1?
    I was in the OrkFramework code and did a flurry of naive "fixes" (45 minutes) to get it compiling to Net 4.6 and 2018.1b11 DLLs. There were a dozen or more "obsolete" errors that blocked compile when importing to VS 2017 that I "fixed". I'm sure you would be much more familiar with the upgrade process for your own code! Unity tried to compile the dll in then gave up due to the instability of my brute force attempt. I can wait for your more guided release... but the Ork / Makinom .Next release sounds exciting.
Sign In or Register to comment.