edited January 8 in ORK Support
Hello, am trying to set my ork input keys horizontal and vertical axis to use unity input manager, but am not getting the desired result. The joystick axis are not responding to input, but the pc keyboard axis seems to be working fine. I will state my unity input manager settings.

Negative button down
Positive button up
Alternate negative button
Alternate positive button
Gravity 2
Dead 0.001
Sensitivity 2
Snap checked
Invert unchecked
Type Key or mouse button
Axis Y axis
Joy Num Get motion from all joysticks
Another problem i noticed, if i set the Type to joystick axis and run the game, my character will start moving without receiving any input from the joystick or pc(i have also tested the joystick in other games. It seems to be working fine)
Post edited by henkesky1 on
  • You need to enable Is Joystick Axis in the ORK input key that uses a joystick from the input manager. They don't have down/hold/up actions like e.g. keyboard input.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • @gamingislove . I have already done that. Still can't figure out why is not working. The joypad works well in other games. I will still buy another joypad and try it out. But if you have other idea as to reason why this might be happening, you can let me know
  • In the Unity input manager, you'll need to use the Joystick Axis type to get joystick input. If the character starts moving without any input, I'd recommend increasing the Dead setting (e.g. to 0.1).
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • @gamingislove Thanks its now working
Sign In or Register to comment.