I'm using the main menu to call scene 1 when loading new game but it wont load scene 1.??
Its loaded in the build settings.
I'm using The Rex Engine as platformer solution.
here is the error code
Scene '1 First Town' couldn't be loaded because it has not been added to the build settings or the AssetBundle has not been loaded.
To add a scene to the build settings use the menu File->Build Settings...
UnityEngine.SceneManagement.SceneManager:LoadScene(String, LoadSceneMode)
ORKFramework.SceneTarget:LoadScene()
ORKFramework.Behaviours.d__25:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

I'm guessing I might have to add the asset bundle but how would I do that?
  • edited October 17
    Make sure the name of the scene and the one you defined in the main menu settings match. E.g. the game tutorial's town scene is named '1 Town'.
    Post edited by gamingislove on
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • Doesn't Work at all. I have successfully done this multiple times but this time its not working. I am using the rex engine for my platformer solution.
    Same old error
    Scene '1 First Town' couldn't be loaded because it has not been added to the build settings or the AssetBundle has not been loaded.
  • Maybe Ork is not compatible with the Rex Engine??
  • I have used the corgi engine and had no problems at all so why is rex causing problems?
  • Is the scene part of an asset bundle? I.e. it's not actually in your project?
    In that case, you'd first have to load the asset bundle before you can load the scene ...

    I don't think this is an issue with a 3rd party product, ORK just tells Unity which scene to load, based on the scene name you define - if there's no scene matching that name added to the build settings (and in your project), Unity can't load the scene.
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
  • how would I go about loading the asset bundle before loading the scene.Sorry I'm a newbie Lol
  • nevermind got it.I had to take the number 1 out of the scene name and it worked..Weird
  • Hm, well, the name should match the name of the scene file ...
    If you're enjoying my products, free updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.