Is it possible when harvesting a tree with turn to event enabled, when finishing the harvest animation, the player to stay in this position and not returning in the starting position?
  • Maybe you could disable turn to event and use rotate to object, i did something like that in one of my prototypes... i hope it helps. :-)
  • Thank you for your reply, I have the same effect, the player gets back to the original position before the event starts, what I think it is causing it is the block controls I have before the chop of the tree.
  • Turn to event doesn't reset the rotation back to the previous rotation (and neither do game events). It might come from your player/camera controls if you're using custom controls ...
  • Yeah I use custom controls, weird it does that, and I used every possible method to delay the stop control in ORK so it has the latest position. When i disable the disable controls node everything works fine, i just need to not move my player while harvesting :P will investigate more.
  • Check the OnEnable and OnDisable functions in your custom controls - they'll be called when ORK enables or disables the control.
  • edited June 22
    I know this is not ORK Related, but if someone can help would be cool.

    this is my OnEnable and OnDisable:

    private void OnEnable()
    {
    GameObject[] gos = GameObject.FindGameObjectsWithTag("Player");
    foreach (GameObject go in gos)
    go.GetComponent().constraints = RigidbodyConstraints.FreezeRotation;

    }
    private void OnDisable()
    {

    GameObject[] gos = GameObject.FindGameObjectsWithTag("Player");
    foreach (GameObject go in gos)
    go.GetComponent().constraints = RigidbodyConstraints.FreezeRotation | RigidbodyConstraints.FreezePosition;

    Cursor.lockState = CursorLockMode.None;
    Cursor.visible = true;
    m_Animator.SetFloat("InputMagnitude", 0);


    Can anyone find something that is causing this? (tried disabling the InDisable freezes but nothing changed. OnEnable if i disable the freeze rotation the player doesnt move.
    Post edited by dlevel on
  • Hm, it might be setting the input magnitude attribute on your animator.
Sign In or Register to comment.