ORK Framework 2.11.1 is here: release notes

This update only adds Unity 5.6 support/requirement - check out ORK 2.11.0 release notes for all the latest features
  • edited May 19
    Great! Iv been waiting for this one.

    Does this fix the camera and player control blocks not working?

    (Not at home...so can't test at this very moment)
    Post edited by paulgswanson on
  • edited May 19
    Unity 5.6.1, when i press play, unity crashes, i had no problem with 2.10.1 (just had the compatibility problems in game).

    I tried deleting ork and reinstall it, still the same problem.

    Also tried 5.6.0f1 same problem, just before unity closes i get the message on console:

    StackOverflowException: The requested operation caused a stack overflow.
    ORKFramework.Group.get_Inventory ()
    Post edited by dlevel on
  • @dlevel
    Hm, strange - can you send me a small Unity test project?
    Since it's crashing when playing, your ORK project asset and maybe the scene you're starting in should be enough ...

    @paulgswanson
    Probably - it wasn't happening on my end, and probably came from an issue with the new UI that's fixed in this version.
  • Ok sending you the exact same test package i created a couple of months ago for the shortcuts equipment box problem, just upgraded to unity 5.6 and ork 2.11.1.

    In this one which is a simple scene, unity doesnt completely crashes, but it has the same error and player doesnt load, so i guess is the same.
  • in case the info is of any use, i've just upgraded to unity5.6, and then upgraded my project (which uses the old UI, not the new-fangled one) to ork2.11.1, and, for me anyway, it all seems to have gone without a hitch

    thanks gil. i don't know when you find time to sleep...
  • Thanks for great update! Been waiting for this one especially.
    Tactics RPG Grid Battle System for ORK
    ---------------------------------------
    I make Dead Gear: http://www.deadgeargame.com
    Twitter: https://twitter.com/Kirbychwan
  • @dlevel
    Yeah, there's an issue when using Individual inventories, I'll soon release ORK 2.11.2 with a fix for that :)
  • edited May 22
    @gamingislove thank you :)
    Post edited by dlevel on
  • hahah I'm and idiot
    The camera issue was totally my fault. I accidentally used spaces in the custom camera name. False alarm! >_> oopsy...

    Just letting you guys know here too since I brought it up.
    Make sure your Camera's behavior name matches the script name not the asset name >_>;
    I even wrote a tutorial on that asset and still buggered it up.
    http://forum.orkframework.com/discussion/3559/tutorial-simple-rpg-camera-setup#latest
Sign In or Register to comment.