edited June 2015 in Makinom Support
You found a bug in Makinom?

Please report them in this thread!
If you encountered an error message in Unity's console - please add them as a quote.
Post edited by gamingislove on
  • seems to be a bug int he raycast system where when using random values to cast the raycast it will cause the object the machine object the cast is comming from to be moved down
    new website can be found here http://www.fore-loregames.com

    Follow the game Development on Twitter https://twitter.com/Fore_Lore_Games

    or check out the face book page here https://www.facebook.com/ForeLoreGames
  • Please give me some details on the node's settings.
  • just to let you know no idea if this is even fixable but calling an ork event from a makinom tick machine is a killer on frame rate itll literally drop it an keep dropping it for no reason even on something as a simple as getting a status value using a ork event
    new website can be found here http://www.fore-loregames.com

    Follow the game Development on Twitter https://twitter.com/Fore_Lore_Games

    or check out the face book page here https://www.facebook.com/ForeLoreGames
  • edited July 2015
    After open "GUI Boxes" by "open in GUI Editor" , when edit the position of element will auto add some "Name Box"
    In current scene.
    Nakinom 1.1.0 Unity 5.1.2
    Post edited by ZhaoYu on
  • (Finally cough up $50 and bought Makinom. Yay! No regrets)

    Well, after upgrading to the offical one, I noticed a bug. In Makinom--> Global Machine, when trying to put the type to KEY, nothing shows up, so you can't really assign a key to it.
    image

    I'm sure that something was here before, because I think I already assigned a key to that global Machine way last time, but now it just disappeared. I checked the Ork global machine, and it gives you the option to assign a key to it when you set the type to KEY. Is this a bug? Or was I just sleep makinoming that time and saw things not there?
  • @Shadow_Fire
    Will be fixed in the next update.
  • In the HUD, trying to open the GUI Editor doesn't work.
  • Will be fixed in the next update :)
  • In the "Change Variables"-Node for the String type variables, the operators "Replace" and "Replace All" seem to do the same (they both replace all occurences).
  • @Ogrims
    Yeah, you're right - will fix that in the next update, thanks :)
  • edited December 2015
    Using Unity 5.3.1f1, and I'm running into an error in the console. It doesn't cause a hang or a crash in editor, but here it is:
    StackOverflowException: The requested operation caused a stack overflow.
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)
    Makinom.Schematics.Schematic.ExecuteNextNode ()
    Makinom.Schematics.Schematic.NodeFinished (Int32 next)

    As far as I can tell, the schematic worked fine in the scene, (in the title screen) but once I started a new game and left the scene while the schematic was in process, this popped up. The schematic is created to loop over and over again until you leave the title screen, if that makes a difference.
    Post edited by Kirb on
    Tactics RPG Grid Battle System for ORK
    ---------------------------------------
    I make Dead Gear: http://www.deadgeargame.com
    Twitter: https://twitter.com/Kirbychwan
  • edited December 2015
    @Kirb
    A stack overflow is usually coming from doing too much stuff in a single frame. How are you repeating the schematic? E.g. if it's just a loop without any kind of wait, that's only logical to happen. There's a security option in the Settings of schematics, to Limit Nodes per Tick to prevent stack overflows.
    I'd need to see the schematic/setup to tell you more.
    Post edited by gamingislove on
  • edited December 2015
    Huh! There were of waits, (generally a randomized 1-5 second wait at the beginning of every loop) but just enabling the limit nodes per tick seems to have stopped the error. Thanks, will remember to check this for big looping schematics. :D
    Post edited by Kirb on
    Tactics RPG Grid Battle System for ORK
    ---------------------------------------
    I make Dead Gear: http://www.deadgeargame.com
    Twitter: https://twitter.com/Kirbychwan
  • edited December 2015
    If you want to repeat a check in a schematic each frame, I'd recommend the Restart Schematic node, which will repeat the schematic in the next frame, without ending it and going back to the machine. Or just use a Tick machine which plays the schematic each frame (Update start type) :)
    Also, if the schematic is looping, it will never end, i.e. you'd need to add a check for the scene if you want to end it when you're not in the main menu scene :)
    Post edited by gamingislove on
  • Either I am doing something wrong or Filter Found Objects doesn't seem to function. To test this:

    1) Create a trigger to activate a Schematic. Use the player to activate it.
    2) Create 2 Cubes nearby.
    3) Set up the Schematic to : Search Objects (Cube/Set) -> Filter Found Objects -> Found Objects Count (>1)
    4) Found Objects Count will return Success regardless of the Filter settings (only tested with Object Checks and Distance Checks). So the filter doesn't seem to be working.
    5) Disabling a single Cube will return Failed, indicating that Found Object Count is working correctly and can tell the difference between Found Objects=1 and Found Objects=2.

    Let me know if you need more information on this.

Sign In or Register to comment.